Recurring Revenue Preview

This Help File Page was last Modified on 03/26/2017

<< Click to Display Table of Contents >>

Navigation:  Accounts Receivable System - The Receivables Module > Receivable Reports - An Overview >

Recurring Revenue Preview

This Help File Page was last Modified on 03/26/2017

One of the most powerful features in the MKMS Accounts Receivable module is the automation of Recurring Revenue Billing.

How much Recurring Revenue will be billed this month, or next month or the month after?

The Recurring Revenue Preview Report will answer this question for any specified Month and Billing Cycle.

With its support for:Billing Cycles groups and Company Divisions it can also also provides Billing previews when your Company is billing the Alarm Dealer's Monitoring Accounts.

 

To access the Recurring Revenue Preview dialog:

a)From the Backstage Menu System Select Reports and Choose Receivable Reports, or  

b)From the Quick Access Menu, Select Reports and Choose Receivable Reports

On the Receivable Reports Menu, Choose the Recurring Revenue Preview option to display the Recurring Revenue Preview dialog shown below.

 

HelpFilesRecurringRevenuePreviewOptions

Recurring Revenue Preview - Options tab

 

Recurring Revenue Preview Report tabs - There are three tabs on the Recurring Revenue Preview dialog.

Options - Initially only the Options tab is shown (until you make your Options selections and Select Print).

Report Type - Specify the required report format.

Detail - By default, Detail is selected which includes the Detail Line Item for each Recurring Revenue item that will be Invoiced.

Summary - Click Summary for the abbreviated version that includes the Subscribers who will be Invoiced and a summarized breakdown of Recurring Revenue by Sales-Category Code..

 

Period To Preview - Use the Drop-Down Selection Lists to enter this information.

Year - By default, it will be the current year unless this is the last Month of the Year, in which case the following Year will be offered.  

oEnter the Year for this preview, if a different Year is required.

Month -By default, it will be the Month following the current Month.  

oEnter the appropriate Month for this preview, as needed.

Cycle - If your Company is using Multiple Billing Cycles (see the "Bill Recurring Revenue in Cycles?" discussion in the Company Options - Invoice/Proposals chapter):

oUse the Drop-Down Selection List to select the appropriate Recurring Billing Cycle for this preview.

 

HelpFilesRecurringRevenuePreviewOptions-NoCycles

Recurring Revenue Preview - Not using Multiple Billing Cycles

 

oOtherwise, as shown above, this field will not be available.

Note: Recurring Revenue is batched, tracked and stored within MKMS by a combination of the Year, Month and Billing Cycle.

If your Company is not using Multiple Billing Cycles, the default "Standard" cycle is used.

 

Last Period Billed - Year, Month and Billing Cycle information for the last time Recurring Revenues were Invoiced.

 

Order by Subscriber ID? - By default, the report prints in alphabetical order by Subscriber Name.  

Check this box to print the report in Subscriber ID order.

 

Division - By default, no Division is selected, therefore all Divisions will be reported.  

To limit the report to a specific Division:

a)Check the Division box.

b)Use the Drop-Down Selection List to Choose the Division that is to be reported.

Print - Click the Print button HelpFilesPrintButton to Preview and optionally Print (to a File or a Printer) this Recurring Revenue Preview Report.

To Exit this Report dialog, Click the Close button HelpFilesReportDialogCloseButton toward the bottom of the Options tab.

 

 

Preview - The Preview tab presents the report which resulted from the Options you've selected.

Up Arrow/Down Arrow - hi - Moves the report one line up, or one line line down, respectively.

Page Up/Page Down - Moves the report to the previous or next page, respectively.

 

HelpFilesRecurringRevenuePreviewPreview

Recurring Revenue Preview - Preview tab - Detail format

Home - HelpFilesHomeKey- Using either the screen Icon or your Keyboard's Home key, moves the report to the top of the first page.

End - HelpFilesEndKey- Using either the screen Icon or your Keyboard's End key, moves the report to the bottom of the last page.

Arrows - The arrows allow you to move back and forth, from page to page.

Number - Indicates the page number you are viewing.

You may also type in a specific page number, Press 8 Enter and that page will be displayed immediately.

If you enter an invalid page number, it will be ignored.

Fit To Page - Click the first button after the arrows to size a full page of the report to fit the screen.

Zoom To 100% - Click the second button after the arrows to display the page at 100% (of the printed view).

Fit To Page Width - Click the third button after the arrows to size the page of the report to fit the full width of the screen.

Zoom To Percentage - Click the fourth button after the arrows to re-size the page of the report by percentage.

 

HelpFilesPercentageOfViewAdjuster

When you Click the Zoom To Percentage button, the Percentage selector will be displayed.

You may then Click the Up  or Down arrow to set the exact amount of Zoom you want.

Subscriber Record Number - Click the record number (listed in blue and underlined) of any Subscriber to open the Subscribers Form for that Subscriber.

Print - Click the Print button to Print (to a File or a Printer) HelpFilesPrintIconthe displayed Revenue by Type and Year Report.

Email - Click the Email button HelpFilesEmailButtonto send the Report to an Email Address of your choosing.

To Exit the Preview tab and Close this Report dialog Form, Click the Close box HelpFilesCloseBoxon the right at the top of the Preview tab.

 

HelpFilesRecurringRevenuePreviewReportSample

Recurring Revenue Preview - Preview tab - Summary format

 

Data View - This view provides a tabular (spreadsheet style) presentation of the selected data.

 

HelpFilesRecurringRevenuePreviewDataView

Recurring Revenue Preview Report - Data View tab

 

Arrows - Click the arrows to move through the record.

Export - Exporting the data from this Data View tab (note the "fly-over" help available on these buttons):

Export to CSV - Click the first button after the arrows to export the data to a Comma Separated Values (CSV) file format.

Export To Excel - Click the second button after the arrows to export the data to an Excel (.xls) file format.

Export To Html - Click the third button after the arrows to export the data to an HTML formatted file.

To Exit the Data View tab and Close this Report dialog Form, Click the Close box HelpFilesCloseBoxon the right at the top of the Data View tab.