Calls Report

This Help File Page was last Modified on 11/10/2017

<< Click to Display Table of Contents >>

Navigation:  Accounts Receivable System - The Receivables Module > Other Reports >

Calls Report

This Help File Page was last Modified on 11/10/2017

The Calls Report offers several ways to select which Calls data is to be included.

The Calls Report provides a detailed listing of the information that may then be filtered in multiple ways to be able to customize which Calls are actually included.

To access the Calls Report dialog:

a)From the Backstage Menu System Select Reports and Choose Calls, or

b)From the Quick Access Menu, Select Reports and Choose Calls

c)From a Subscribers, Prospects, and/or Vendors Form, Click the Calls Icon on that Form's Menu

 

The Calls Report dialog will be display (sometimes with specific changes noted later) as shown below.

 

HelpFilesCallsReportOptions

Calls Report - Options tab

 

Using the Search dialog: When using the Calls Report dialog, there is often a need to locate a set of one or more specified Subscribers, Prospects, Vendors, and/or Employees:

This is because certain options (explained below) will require the User to execute a Search procedure to identify those desired Subscribers, Prospects, Vendors, and/or Employees:.

Because of the (potentially) long list of records that could be presented in the Search dialog, use this technique to locate a specific set of one or more record(s):

 

HelpFilesCallsReportSubscriberSearchDialog-SubscriberColumn

Search dialog - Subscriber column active

 

By default, these Accounts will be listed alphabetically by the Subscriber (name):

a)To locate and select the required Subscriber record(s):

i.Click on any Name within the Subscriber column

ii.Press F2 to position the cursor (and clear any previous entries) in the(F2)-Search field.

iii.Enter first few characters of the Subscriber's Name which will be compared to the data in that Column.

iv.As characters are entered, an incremental search is performed on the data within the Subscriber Column.

b)Check the Selected box for the desired record when that record are located.

c)Repeat this process until all of the required records have been chosen (Checked).

d)Click the OK button to close the Search dialog and insert the selected record number(s) in the Search field.

 

To execute a Search on a different type of data (e.g., CSID, Zip, City):

a)Expand the width of the Search dialog (if needed) by Dragging the right side's border to the right.

 

HelpFilesCallsReportSubscriberSearchDialogSlideBar

Search dialog - CSID data chosen, Slide Bar

 

b)Using the Slide Bar at the bottom of the Search dialog to view all of the available data Header Names, locate the Header Name on which the Search should be performed

i.Click on the first Field within the first record line of that Column to Choose - thus making it the Header Name data that is to be searched.

ii.Press F2 to position the cursor (and clear any previous entries) in the(F2)-Search field.

iii.Enter characters for the search which will then be compared to the data in the selected Column.

iv.As characters are entered, an incremental search is performed on the data within that Column.

c)Check the Selected box(es) for the desired record(s) when those desired record(s) are located.

d)Repeat this process until all the required records to be reported have been Checked.

e)Click the OK button to Close the Search dialog

 

The selected record ID's (as shown in the illustration below) will be inserted into the designated Selection field.

 

HelpFilesGreenSelectFieldWithEllipse

 

If a necessary selection is not made, when the Print button is selected, an error message will be displayed:

 

HelpFilesCallsReportMissingSelectionError

 

oClick OK and then make the required selection(s) using the method described above.

 

Calls Report tabs - There are three tabs on the Calls Report dialog.

Options - Initially only the Options tab is shown (until you Choose your Options and Select Print).

 

HelpFilesCallsReportOptions

Calls Report - Options tab

 

Report On - Click on the appropriate button to select which Call Entries are to be included in this report:

When this Calls Report was opened from the a Subscribers, Prospects, and/or Vendors Form's Ribbon Menu , there are no Report On options available.

 

HelpFilesCallsReportOnSelectionBox

Report On box - Selection field

 

Subscribers & Prospects - By default, All Call Entries for both Subscribers and Prospects are to be included.

Subscribers - Only include Call Entries for Subscribers.

Prospects -  Only include Call Entries for Prospects.

Specific Subscribers -  Only include Call Entries to or from one or more specified Subscribers.

oSpecific - The Subscriber(s) field will be displayed below the Report On box.

oClick the Ellipse HelpFilesEllipseButton  to Open the Search dialog shown below.

 

HelpFilesCallsReportSubscriberSearchDialog-SubscriberColumn

Search dialog

 

oCheck as many Subscriber records as needed to identify whose Call Entries are to be included in the report.

 

Specific Prospects - Only include Call Entries to or from one or more specified Prospects.

oSpecific - The Prospect(s) field will be displayed.

oClick the Ellipse HelpFilesEllipseButton  to Open the Search dialog shown below.

 

HelpFilesProspectSearchMultipleRecords

Prospect Selection dialog - expanded view

 

oCheck each Prospect whose Call Entries are to be included in the report.

Use the method outlined above in "Using the Search dialog" to make your Prospect selection(s)

 

Vendors - Just Call Entries for Vendors are to be included.

 

Specific Vendors - Only include Call Entries to or from one or more specified Vendors are to be included.

oSpecific - The Vendor(s) field will be displayed.

oClick the Ellipse HelpFilesEllipseButton  to Open the Search dialog shown below.

 

HelpFilesVendorsSearchMultipleRecords

Vendor Selection dialog

 

oCheck each Vendor whose Call Entries are to be included in the report.

Use the method outlined above in "Using the Search dialog" to make your Vendor selection(s)

 

Date Range - Enter the time frame, based on when the Calls were recorded, for Call Entries that are to be included.

a)Click on the Date field and type the desired Date using a MM/DD/YYYY format; or

b)Use the Drop-Down Calendar/Date Entry field provided to Choose the desired Date

 

HelpFilesCallsReportDateRange

From - By default, the Starting Date will be one month prior to Today at 8:00AM.

oWhen this Calls Report was opened from the a Subscribers, Prospects, and/or Vendors Form's Ribbon Menu , the First Call's Date in their Call History List will be inserted..

oUse the Drop-Down Calendar/Date Entry field to Choose a different Starting Date, if required.

oModify the Starting Time, if appropriate.

To - By default, the Ending Time will be Today at 8:00PM.

oWhen this Calls Report was opened from the a Subscribers, Prospects, and/or Vendors Form's Ribbon Menu , the Last Call's Date in their Call History List will be inserted..

oUse the Drop-Down Calendar/Date Entry field to Choose a different Ending Date, if required.

oModify the Ending Time, if appropriate.

 

Employees - Click on the appropriate button to include Calls recorded by All Employees, or Limit the Call Entries to specific Employee(s).

All - By default, every Employee's Calls will be included.

Specific - Choose which Employee(s) Calls will be included.

 

HelpFilesCallsReportEmployees

 

oSpecific - The Employee field will be displayed.

oClick the Ellipse HelpFilesEllipseButton  to Open the Search dialog shown below.

 

HelpFilesEmployeesSearchMultipleRecords

Employee Search dialog

 

oCheck each Employee whose Call Entries are to be included in the report.

oUse the method outlined above in "Using the Search dialog" to make your Employee selection(s)

 

Call Source - Click on the appropriate button to include Calls assigned a specific Call Source.

All - By default, all Call Sources will be included.

Specific - The Call Source field will be displayed.

oClick the Ellipse to Open the Search dialog shown below.

 

HelpFilesCallsSearchMultipleRecords

Calls Search dialog

 

oCheck each Call Source to be included in the report.

Use the method outlined above in "Using the Search dialog" to make your Call Source selection(s)

 

Call Status - Calls may be Open (unfinished) or Closed (completed).

All - By default, all Calls will be included.

Open - Click Open to have only the unfinished Calls included.

Closed - Click Closed to have only the completed Calls included.

 

Sort By - The Calls Report results may be sorted as follows:

Call Status - Click this button when you want the Calls Report, based on the filtering selections made above, then sorted by Employees, and then for each Employee, by each Prospect's Closed Calls and then their Open Calls, then by each Subscriber's Closed Calls and then their Open Calls.

Call Source - Click this button when you want the Calls Report, based on the filtering selections made above, then sorted by Employees, and then for each Employee, by Call  Date in Call Source order.

Call Type - Click this button when you want the Calls Report, based on the filtering selections made above, then sorted by Employees, then by Prospects followed by Subscribers (if both were requested), and within each by Call Type.

Date - Click this button when you want the Calls Report, based on the filtering selections made above, then sorted by Employees, then by Prospects in Call Date Order followed by Subscribers in Call Date Order.

 

Show Call Data? - Click this button to include the detail of each Call in the Calls Report

 

Charts - Using the Drop-Down Selection List provided, you may request that a Pie or Bar Chart be included as part of this report's output.

Print - Click the Print button HelpFilesPrintButtonto Preview and optionally Print (to a File or a Printer) this Calls Report.

To Exit this Report dialog, Click the Close button HelpFilesReportDialogCloseButton toward the bottom of the Options tab.

 

Preview - The Preview tab presents the Calls Report which resulted from the Options you've selected.

 

HelpFilesCallsReportPreview

Calls Report - Preview tab - No Call Data detail

Home - HelpFilesHomeKey- Using either the screen Icon or your Keyboard's Home key, moves the report to the top of the first page.

End - HelpFilesEndKey- Using either the screen Icon or your Keyboard's End key, moves the report to the bottom of the last page.

Arrows - The arrows allow you to move back and forth, from page to page.

Number - Indicates the page number you are viewing.

You may also type in a specific page number, Press 8 Enter and that page will be displayed immediately.

If you enter an invalid page number, it will be ignored.

Fit To Page - Click the first button after the arrows to size a full page of the report to fit the screen.

Zoom To 100% - Click the second button after the arrows to display the page at 100% (of the printed view).

Fit To Page Width - Click the third button after the arrows to size the page of the report to fit the full width of the screen.

Zoom To Percentage - Click the fourth button after the arrows to re-size the page of the report by percentage.

 

HelpFilesPercentageOfViewAdjuster

When you Click the Zoom To Percentage button, the Percentage selector will be displayed.

You may then Click the Up  or Down arrows to set the exact amount of Zoom you want.

Print - Click the Print button to Print (to a File or a Printer) HelpFilesPrintIconthe displayed Calls Report.

Email - Click the Email button HelpFilesEmailButtonto send the Report to an Email Address of your choosing.

To Exit the Preview tab and Close this Report dialog Form, Click the Close box HelpFilesCloseBoxon the right at the top of the Preview tab.

 

Data View - This view provides a tabular (spreadsheet style) presentation of the selected data.

 

HelpFilesCallsReportDataView

 

Arrows - Click the arrows to move through the record.

Export - Exporting the data from this Data View Form (note the "fly-over" help available on these buttons):

Export to CSV - Click the first button after the arrows to export the data to a Comma Separated Values (CSV) file format.

Export To Excel - Click the second button after the arrows to export the data to an Excel (.xls) file format.

Export To Html - Click the third button after the arrows to export the data to an HTML formatted file.

To Exit the Data View tab and Close this Report dialog Form, Click the Close box HelpFilesCloseBoxon the right at the top of the Data View tab.